<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
			<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<meta name="theme-color" content="#f00084">
	
	<!-- This site is optimized with the Yoast SEO plugin v14.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Peel &#039;catch and release&#039; icy post-punk on their self-titled EP</title>
	<meta name="description" content="Fast Tracked: Instead of clinging too tightly to their inspirations, the L.A. duo find themselves drifting towards their own glacial &#039;wall of sound&#039; approach." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Peel &#039;catch and release&#039; icy post-punk on their self-titled EP" />
	<meta property="og:description" content="Fast Tracked: Instead of clinging too tightly to their inspirations, the L.A. duo find themselves drifting towards their own glacial &#039;wall of sound&#039; approach." />
	<meta property="og:url" content="https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/" />
	<meta property="og:site_name" content="Vanyaland" />
	<meta property="article:publisher" content="http://facebook.com/vanyaland617" />
	<meta property="article:author" content="https://www.facebook.com/100008327772427" />
	<meta property="article:published_time" content="2020-10-16T18:01:59+00:00" />
	<meta property="article:modified_time" content="2020-10-16T18:12:43+00:00" />
	<meta property="og:image" content="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack.jpeg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1230" />
	<meta property="fb:app_id" content="684274505473008" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@vanyaland617" />
	<meta name="twitter:site" content="@vanyaland617" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vanyaland.com/#website","url":"https://vanyaland.com/","name":"Vanyaland","description":"Music, Film &amp; Beyond","potentialAction":[{"@type":"SearchAction","target":"https://vanyaland.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/#primaryimage","inLanguage":"en-US","url":"https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack.jpeg","width":1920,"height":1230,"caption":"Photo Credit: David Black"},{"@type":"WebPage","@id":"https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/#webpage","url":"https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/","name":"Peel 'catch and release' icy post-punk on their self-titled EP","isPartOf":{"@id":"https://vanyaland.com/#website"},"primaryImageOfPage":{"@id":"https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/#primaryimage"},"datePublished":"2020-10-16T18:01:59+00:00","dateModified":"2020-10-16T18:12:43+00:00","author":{"@id":"https://vanyaland.com/#/schema/person/7b37f0e058049c618ef7d69f5975cb1d"},"description":"Fast Tracked: Instead of clinging too tightly to their inspirations, the L.A. duo find themselves drifting towards their own glacial 'wall of sound' approach.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/"]}]},{"@type":["Person"],"@id":"https://vanyaland.com/#/schema/person/7b37f0e058049c618ef7d69f5975cb1d","name":"Victoria Wasylak","sameAs":["https://www.facebook.com/100008327772427"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Vanyaland &raquo; Feed" href="https://vanyaland.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Vanyaland &raquo; Comments Feed" href="https://vanyaland.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vanyaland.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://vanyaland.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://vanyaland.com/wp-content/plugins/theia-post-slider/css/font-theme.css?ver=1.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='https://vanyaland.com/wp-content/plugins/theia-post-slider/fonts/style.css?ver=1.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='zeen-style-css'  href='https://vanyaland.com/wp-content/themes/redefined_theme/assets/css/style.min.css?ver=3.9.4' type='text/css' media='all' />
<style id='zeen-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='redefined_theme-child-style-css'  href='https://vanyaland.com/wp-content/themes/zeen-child/style.css?ver=3.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='zeen-fonts-css'  href='https://fonts.googleapis.com/css?family=Average%3A400%2Citalic%7CRoboto%3A400%2C700%7CRoboto%3A100%2C700&#038;subset=latin&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='swipebox-css'  href='https://vanyaland.com/wp-content/themes/redefined_theme/assets/css/swipebox.min.css?ver=1.4.4' type='text/css' media='all' />
<script type='text/javascript' src='https://vanyaland.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/theia-post-slider/js/hammer.min.js?ver=2.0.4'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.9.0'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.9.0'></script>
<!--[if IE]>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/ie9.js?ver=3.9.4'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://vanyaland.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vanyaland.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vanyaland.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://vanyaland.com/?p=10023560' />
<link rel="alternate" type="application/json+oembed" href="https://vanyaland.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://vanyaland.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.4.1 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script data-ad-client="ca-pub-1293177065639765" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>		<style>
			.theiaPostSlider_nav.fontTheme ._title,
			.theiaPostSlider_nav.fontTheme ._text {
				line-height: 40px;
			}

			.theiaPostSlider_nav.fontTheme ._button {
				color: #f00084;
			}

			.theiaPostSlider_nav.fontTheme ._button ._2 span {
				font-size: 40px;
				line-height: 40px;
			}

			.theiaPostSlider_nav.fontTheme ._button:hover,
			.theiaPostSlider_nav.fontTheme ._button:focus {
				color: #ff38a5;
			}

			.theiaPostSlider_nav.fontTheme ._disabled {
				color: #777777 !important;
			}
		</style>
		<!-- Google Analytics -->
	<script>
	window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
	ga('create', 'UA-41480406-1', 'auto');
	ga('send', 'pageview');
		</script>
	<!-- End Google Analytics -->
	<link rel="preload" type="font/woff2" as="font" href="https://vanyaland.com/wp-content/themes/redefined_theme/assets/css/tipi/tipi.woff2?9oa0lg" crossorigin><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '219276775956206', {}, {
    "agent": "wordpress-5.4.2-2.0.2"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=219276775956206&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<link rel="icon" href="https://vanyaland.com/wp-content/uploads/2016/11/Vanyaland-Logo-100x100.png" sizes="32x32" />
<link rel="icon" href="https://vanyaland.com/wp-content/uploads/2016/11/Vanyaland-Logo-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://vanyaland.com/wp-content/uploads/2016/11/Vanyaland-Logo-300x300.png" />
<meta name="msapplication-TileImage" content="https://vanyaland.com/wp-content/uploads/2016/11/Vanyaland-Logo-300x300.png" />
		<style type="text/css" id="wp-custom-css">
			.sticky-p2 .pre-title {
    color: #f00084;
		font-family: 'Open Sans', sans-serif;
}

.sticky-p2 .title {
    display: inline-block;
    font-weight: 400;
		font-family: 'Open Sans', sans-serif;
}

.wpcf7-mail-sent-ok {
    background: #000;
}

.block-css-34767 .cats .cat-with-bg-dark {
	background: #111;
}

.block-css-33110 .preview-classic .byline-1 .byline-part a {
    visibility: hidden;
}
		</style>
		</head>
<body class="post-template-default single single-post postid-10023560 single-format-standard headings-f1 body-f2 sub-f2 quotes-f2 by-f3 wh-f2 block-titles-big block-titles-mid-1 mob-menu-on-tab menu-no-color-hover grids-spacing-0 modal-skin-2 excerpt-mob-off avatar-mob-off skin-light single-sticky-spin footer-widgets-text-white site-mob-menu-a-4 site-mob-menu-2 mm-submenu-1 main-menu-logo-1 body-header-style-81 body-with-v body-hero-l byline-font-3">
	<div id="page" class="site">
		<div id="top-bar-message" class="top-bar-message font-2"><span class="top-bar-message-content"><a href="https://www.vote.org/" rel="nofollow" target="_blank title="&lt;p&gt;&lt;span style=&quot;color: #ffffff&quot;&gt;Vanyaland encourages every American to vote on November 3.&lt;/span&gt; &lt;span style=&quot;color: #f00084&quot;&gt;&lt;b&gt;Click here to register.&lt;/b&gt;&lt;/span&gt;&lt;/p&gt;"><p><span style="color: #ffffff">Vanyaland encourages every American to vote on November 3.</span> <span style="color: #f00084"><b>Click here to register.</b></span></p></a></span><div id="top-bar-message-close"><i class="tipi-i-close"></i></div></div><div id="mob-line" class="tipi-m-0"></div><header id="mobhead" class="site-header-block site-mob-header tipi-m-0 site-mob-header-1 site-mob-menu-2 sticky-menu-mob sticky-menu-1 sticky-top site-skin-3 site-img-1"><div class="bg-area header-padding tipi-row tipi-vertical-c">
	<ul class="menu-left icons-wrap tipi-vertical-c">
		<li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
			
			
	
		</ul>
	<div class="logo-main-wrap logo-mob-wrap">
		<div class="logo logo-mobile"><a href="https://vanyaland.com" data-pin-nopin="true"><img src="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180713/Vanyaland_Logo50.png" alt="" srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180714/Vanyaland_Logo100.png 2x" width="50" height="50"></a></div>	</div>
	<ul class="menu-right icons-wrap tipi-vertical-c">
		<li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" id="mode__wrap" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li>
			
	
			
			
	
			
			
			<li class="menu-icon menu-icon-mobile-slide"><a href="#" class="mob-tr-open" data-target="slide-menu"><i class="tipi-i-menu-mob" aria-hidden="true"></i></a></li>
	
		</ul>
	<div class="background"></div></div>
</header><!-- .site-mob-header --><div id="site-header-side" class="site-header-side secondary-wrap header-padding secondary-wrap-v bg-area site-skin-2 site-img-1 site-header-side-narrow site-header-no-menu v-wrap-l tipi-xs-0 clearfix"><div class="logo-main-wrap"><div class="logo logo-main"><a href="https://vanyaland.com" data-pin-nopin="true"><img src="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180713/Vanyaland_Logo50.png" alt="" srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180714/Vanyaland_Logo100.png 2x" data-base-srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180714/Vanyaland_Logo100.png 2x" data-alt-srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/09/06133215/Vanyaland_Logoglow100-1.png 2x" width="50" height="50"></a></div></div><div class="background"></div><ul class="menu-icons-wrap tipi-flex"><li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/vanyaland617" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-r" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/vanyaland617" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-r" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/vanyalandmusic" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-r" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" id="mode__wrap" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-r" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li><li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-r" data-title="Search" data-type="search"></a></li>
					<li class="menu-icon menu-icon-slide"><a href="#" class="tipi-i-menu slide-menu-tr-open" data-target="slide"></a></li>
	
	
	</ul><span class="menu-placeholder"></span></div>		<div class="site-inner">
						<div id="content" class="site-content clearfix">
			<div id="primary" class="content-area">

	<div class="post-wrap clearfix article-layout-skin-1 title-above-c hero-l sidebar-off-wide align-fs post-10023560 post type-post status-publish format-standard has-post-thumbnail hentry category-music category-national-news tag-catch-release tag-innovative-leisure tag-peel">
		<div class="meta-wrap hero-meta tipi-xl-typo elements-design-2 clearfix tipi-row content-bg"><div class="meta meta-no-sub"><div class="byline byline-2 byline-cats-design-3"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://vanyaland.com/category/music/" style="border-bottom-color:#f00084" class="cat cat-with-line">Music</a><a href="https://vanyaland.com/category/music/national-news/" style="border-bottom-color:#f00084" class="cat cat-with-line">National News</a></div></div><div class="title-wrap"><h1 class="entry-title title flipboard-title">Peel &#8216;catch and release&#8217; icy post-punk on their self-titled EP</h1></div><div class="byline byline-3"><span class="byline-part author"><a class="url fn n" href="https://vanyaland.com/author/victoria-wasylak/"><span class="byline-by byline-detail">By </span><span class="byline-by-name">Victoria Wasylak</span></a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2020-10-16T14:01:59-04:00">October 16, 2020</time></span></div></div><div class="share-it share-it-2 share-it-bold share-it-count-0 share-it-below_title tipi-flex"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F" class=" share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://twitter.com/intent/tweet?via=vanyaland617&#038;text=Peel%20%E2%80%98catch%20and%20release%E2%80%99%20icy%20post-punk%20on%20their%20self-titled%20EP%20-%20https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F" class=" share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i><span class="social-tip font-base font-1">Tweet</span></span></a></div></div><!-- .meta-wrap --><div class="hero-wrap clearfix hero-26 cover-1 no-par"><div class="hero"><img width="1920" height="1230" src="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack.jpeg" class="flipboard-image wp-post-image" alt="" srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack.jpeg 1920w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-800x513.jpeg 800w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-1160x743.jpeg 1160w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-770x493.jpeg 770w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-1536x984.jpeg 1536w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-174x111.jpeg 174w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-651x417.jpeg 651w, https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/10/16132224/Peel_CreditDavidBlack-1281x821.jpeg 1281w" sizes="(max-width: 1920px) 100vw, 1920px" /></div><div class="caption">Photo Credit: David Black</div></div>		<div class="single-content contents-wrap tipi-row content-bg clearfix article-layout-55">
			<div class="tipi-cols clearfix sticky--wrap">
				<main class="site-main tipi-xs-12 main-block-wrap block-wrap tipi-l-8 tipi-col clearfix">
		<article>
						<div class="entry-content-wrap clearfix">
									<div class="block-da-1 block-da block-da-post_before_content clearfix"><div class="a-single a-17"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Horizontal - Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1293177065639765"
     data-ad-slot="5757238574"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	
&nbsp;</div>												<div class="entry-content body-color clearfix link-color-wrap">
																										<div id="tps_slideContainer_10023560" class="theiaPostSlider_slides"><div>

<p>Somewhere, from a concrete loft above The Orpheum Theatre in Los Angeles, <strong><a href="https://peelband.bandcamp.com/">Peel</a></strong> nearly emerged completely frostbitten, with their self-titled debut EP in tow. The L.A. duo of multi-instrumentalists and Foster The People bandmates Sean Cimino and Isom Innis &#8212; the latter of which did time in Boston years ago as Southern Belle &#8212; had an ear for all things icy as they prepared the five tracks of <em>Peel</em> (out today via Innovative Leisure). The duo were moved by mutual &#8220;obsessions&#8221; like Gary Numan&#8217;s 1979 magnum opus <em>The Pleasure Principle</em> and Public Image Ltd.&#8217;s album <em>Second Edition</em> from the same year. </p>



<p>But like their EP&#8217;s first track explains, Peel have already mastered the art of &#8220;Catch &amp; Release.&#8221; Instead of clinging too tightly to their musical inspirations, Innis and Cimino find themselves drifting towards their own glacial &#8220;wall of sound&#8221; approach. And that&#8217;s just the tip of their proverbial iceberg. </p>



<p>Tune in below.</p><div class="EA1RPJnd" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"> 
<div class="a-single a-21"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Horizontal - Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1293177065639765"
     data-ad-slot="5757238574"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	
 </div>



<p><iframe src="https://open.spotify.com/embed/album/13HQQNbRWswWtuzwiNWTG6" width="100%" height="480" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe></p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p><div class="8zQQPFlr" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"> 
<div class="a-single a-21"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Horizontal - Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1293177065639765"
     data-ad-slot="5757238574"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	
 </div></p>
                <script type='text/javascript'>
                    
                var tpsInstance;
                var tpsOptions = {"slideContainer":"#tps_slideContainer_10023560","nav":[".theiaPostSlider_nav"],"navText":"%{currentSlide} of %{totalSlides}","helperText":"Swipe or use your &leftarrow; &rightarrow; (arrow) keys","defaultSlide":0,"transitionEffect":"slide","transitionSpeed":100,"keyboardShortcuts":true,"scrollAfterRefresh":true,"numberOfSlides":1,"slides":[],"useSlideSources":true,"themeType":"font","prevText":"Prev","nextText":"Next","buttonWidth":"0","buttonWidth_post":"0","postUrl":"https:\/\/vanyaland.com\/2020\/10\/16\/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep\/","postId":10023560,"refreshAds":true,"refreshAdsEveryNSlides":"1","adRefreshingMechanism":"page","siteUrl":"https:\/\/vanyaland.com","loopSlides":true,"scrollTopOffset":"0","prevFontIcon":"<span aria-hidden=\"true\" class=\"tps-icon-arrow-left19\"><\/span>","nextFontIcon":"<span aria-hidden=\"true\" class=\"tps-icon-arrow-right19\"><\/span>"};
            
                    (function ($) {
                        $(document).ready(function () {
                            
                            tpsInstance = new tps.createSlideshow(tpsOptions);
                        });
                    }(jQuery));
                </script>
            									</div><!-- .entry-content -->
							</div><!-- .entry-content -->

			<footer class="entry-footer">
				<div class="post-tags footer-block-links clearfix"><div class="title">Tags</div><div class="block-elements"><a href="https://vanyaland.com/tag/catch-release/" rel="tag">catch &amp; release</a><a href="https://vanyaland.com/tag/innovative-leisure/" rel="tag">Innovative Leisure</a><a href="https://vanyaland.com/tag/peel/" rel="tag">Peel</a></div></div><div class="block-da-1 block-da block-da-post_end clearfix"><div class="a-single a-20"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Horizontal - Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1293177065639765"
     data-ad-slot="5757238574"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>	</div>			</footer><!-- .entry-footer -->
		</article><!-- #post-x -->
	</main><!-- .site-main -->
				</div><!-- .tipi-cols -->
					</div><!-- .tipi-row -->
			</div><!-- .post-wrap -->
		<span class="ipl" data-title-prev="Peel &#8216;catch and release&#8217; icy post-punk on their self-titled EP" data-next-hex="#f00084" data-prev-hex="#f00084" data-title-next="Lana Del Rey comforts a damaged world with &#8216;Let Me Love You Like A Woman&#8217;" data-pid="10023554" data-pidori="10023560" data-prev="https://vanyaland.com/2020/10/16/peel-catch-and-release-icy-post-punk-on-their-self-titled-ep/" data-next="https://vanyaland.com/2020/10/16/lana-del-rey-comforts-a-damaged-world-with-let-me-love-you-like-a-woman/"></span>
</div><!-- .content-area -->
<div id="ipl-loader" class="ipl-loader tipi-spin"></div>		</div><!-- .site-content -->
				<footer id="colophon" class="site-footer site-footer-1 site-img-1 widget-area-borders-1 footer-fs  widget-title-default footer__mob__cols-1 clearfix">
			<div class="bg-area">
								<div class="bg-area-inner">
										<div class="footer-lower-area footer-area clearfix site-skin-2">
	<div class="tipi-row">
		<div class="logo logo-footer"><a href="https://vanyaland.com" data-pin-nopin="true"><img src="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/09/06132423/Vanyaland_LogoW60.png" alt="" srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2020/09/06132421/Vanyaland_LogoW120.png 2x" width="60" height="60"></a></div>					<nav id="footer-navigation" class="footer-navigation clearfix font-2">
		<ul id="menu-footer-menu" class="footer-menu horizontal-menu"><li id="menu-item-98532" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-98532"><a href="https://vanyaland.com/about/">Masthead</a></li>
<li id="menu-item-25918" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-25918"><a href="https://vanyaland.com/copyright/">Copyright</a></li>
<li id="menu-item-23397" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-23397"><a href="https://vanyaland.com/terms/">Terms of Use</a></li>
<li id="menu-item-10000035" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-10000035"><a href="mailto:advertising@thisisredefined.com">Advertising</a></li>
<li id="menu-item-98533" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-98533"><a href="https://vanyaland.com/contact/">Contact</a></li>
</ul>	</nav><!-- .footer-navigation -->
					<div class="copyright font-2 copyright-l">© 2020 Vanyaland | Redefined. All rights reserved. Use of and/or registration on any portion of this site constitutes acceptance of our User Agreement and Privacy Policy and Cookie Statement. The material on this site may not be reproduced, distributed, transmitted, cached or otherwise used, except with prior written permission of Redefined.</div>
		</div>
</div>
					<div class="background"></div>				</div>
			</div>
		</footer><!-- .site-footer -->
				
	</div><!-- .site-inner -->

</div><!-- .site -->
<div id="mob-menu-wrap" class="mob-menu-wrap mobile-navigation-dd tipi-m-0 site-skin-2 site-img-1">
	<div class="bg-area">
		<a href="#" class="mob-tr-close tipi-close-icon"><i class="tipi-i-close" aria-hidden="true"></i></a>
		<div class="content-wrap">
			<div class="content">
				<div class="logo logo-mobile-menu"><a href="https://vanyaland.com" data-pin-nopin="true"><img src="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180713/Vanyaland_Logo50.png" alt="" srcset="https://s3-us-east-2.amazonaws.com/redefined/wp-content/uploads/2018/10/23180714/Vanyaland_Logo100.png 2x" width="50" height="50"></a></div>								<nav class="mobile-navigation mobile-navigation-1"><ul id="menu-mobile" class="menu-mobile vertical-menu font-2"><li id="menu-item-150709" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropper standard-drop menu-item-150709"><a href="/category/national-news">Music</a>
<ul class="sub-menu">
	<li id="menu-item-91305" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-91305"><a href="/category/national-news">National News</a></li>
	<li id="menu-item-91304" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-91304"><a href="/category/boston-news">Boston News</a></li>
	<li id="menu-item-110249" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-110249"><a href="/category/providence-news">Providence News</a></li>
	<li id="menu-item-10000350" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-10000350"><a href="https://vanyaland.com/category/music/phoenix-news/">Phoenix News</a></li>
	<li id="menu-item-91306" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-91306"><a href="/category/reviews">Reviews</a></li>
</ul>
</li>
<li id="menu-item-91308" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-91308"><a href="/category/photo-gallery">Photos</a></li>
<li id="menu-item-150705" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-150705"><a href="https://vanyaland.com/category/comedy/">Comedy</a></li>
<li id="menu-item-150707" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-150707"><a href="https://vanyaland.com/category/filmtv/">Film/TV</a></li>
<li id="menu-item-91310" class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-91310"><a href="/category/spotlight">Spotlight</a></li>
<li id="menu-item-151062" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-151062"><a href="https://vanyaland.com/category/community/">V:Com</a></li>
</ul></nav><!-- .mobile-navigation -->				<ul class="menu-icons horizontal-menu">
					<li  class="menu-icon menu-icon-style-2 menu-icon-fb"><a href="https://facebook.com/vanyaland617" data-title="Facebook" class="tipi-i-facebook" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-2 menu-icon-tw"><a href="https://twitter.com/vanyaland617" data-title="Twitter" class="tipi-i-twitter" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-2 menu-icon-insta"><a href="https://instagram.com/vanyalandmusic" data-title="Instagram" class="tipi-i-instagram" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li>
			
	
					</ul>
			</div>
		</div>
		<div class="background"></div>	</div>
</div>
<div id="slide-in-menu" class="slide-in-menu site-skin-1 site-img-1 tipi-tile tipi-xs-0">
	<a href="#" class="tipi-i-close modal-tr-close close tipi-close-icon"></a>	<div class="bg-area">
		<div class="content clearfix">
							<div id="zeen_social_icons-2" class="slide-in-widget zeen-widget clearfix zeen_social_icons"><h3 class="widget-title title">FOLLOW VANYALAND</h3><div class="social-widget-icons social-align-0">			<ul>
							<li>
					<a href="https://facebook.com/vanyaland617" class="tipi-i-facebook tipi-i-sz-1 zeen-social-icons-dark" data-title="" rel="noopener" target="_blank"></a>
				</li>
							<li>
					<a href="https://twitter.com/vanyaland617" class="tipi-i-twitter tipi-i-sz-1 zeen-social-icons-dark" data-title="" rel="noopener" target="_blank"></a>
				</li>
							<li>
					<a href="https://instagram.com/vanyalandmusic" class="tipi-i-instagram tipi-i-sz-1 zeen-social-icons-dark" data-title="" rel="noopener" target="_blank"></a>
				</li>
						</ul>
		</div>

		</div><div id="nav_menu-5" class="slide-in-widget zeen-widget clearfix widget_nav_menu"><div class="menu-v3-0-container"><ul id="menu-v3-0" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropper standard-drop menu-item-150709"><a href="/category/national-news">Music</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-91305"><a href="/category/national-news">National News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-91304"><a href="/category/boston-news">Boston News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-110249"><a href="/category/providence-news">Providence News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-10000350"><a href="https://vanyaland.com/category/music/phoenix-news/">Phoenix News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop menu-item-91306"><a href="/category/reviews">Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-91308"><a href="/category/photo-gallery">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-150705"><a href="https://vanyaland.com/category/comedy/">Comedy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-150707"><a href="https://vanyaland.com/category/filmtv/">Film/TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-91310"><a href="/category/spotlight">Spotlight</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-151062"><a href="https://vanyaland.com/category/community/">V:Com</a></li>
</ul></div></div>		</div>
		<div class="background"></div>	</div>
</div>
<div id="modal" class="modal-wrap inactive dark-overlay" data-fid="">
	<span class="tipi-overlay tipi-overlay-modal"></span>
	<div class="content tipi-vertical-c tipi-row">
		<div class="content-search search-form-wrap content-block">
			<form method="get" class="search tipi-flex" action="https://vanyaland.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
			<div class="search-hints">
				<span class="search-hint">
					Start typing to see results or hit ESC to close				</span>
				<div class="suggestions-wrap font-2"><a href="https://vanyaland.com/tag/boston-3/" class="tag-cloud-link tag-link-142 tag-link-position-1" style="font-size: 12px;">Boston</a>
<a href="https://vanyaland.com/tag/cambridge/" class="tag-cloud-link tag-link-16738 tag-link-position-2" style="font-size: 12px;">Cambridge</a>
<a href="https://vanyaland.com/tag/allston/" class="tag-cloud-link tag-link-16726 tag-link-position-3" style="font-size: 12px;">Allston</a>
<a href="https://vanyaland.com/tag/boston-calling/" class="tag-cloud-link tag-link-16732 tag-link-position-4" style="font-size: 12px;">Boston Calling</a>
<a href="https://vanyaland.com/tag/film-review/" class="tag-cloud-link tag-link-20180 tag-link-position-5" style="font-size: 12px;">Film Review</a></div>			</div>
			<div class="content-found-wrap"><div class="content-found"></div><div class="button-wrap"><a class="search-all-results button-arrow-r button-arrow tipi-button" href="#"><span class="button-title">See all results</span><i class="tipi-i-arrow-right"></i></a></div></div>		</div>

				<div class="content-lwa content-block site-img-1 site-skin-2">
				</div>

		<div class="content-custom content-block">
		</div>
	</div>
	<a href="#" class="close tipi-x-wrap tipi-x-outer"><i class="tipi-i-close"></i></a>

</div>
<span id="tipi-overlay" class="tipi-overlay tipi-overlay-base tipi-overlay-dark"><a href="#" class="close tipi-x-wrap"><i class="tipi-i-close"></i></a></span>
<div id="mob-bot-share" class="mob-bot-share tipi-m-0 mob-bot-share-2">
	<div class="share-buttons">
		<a href="https://twitter.com/intent/tweet?via=vanyaland617&#038;text=Peel%20%E2%80%98catch%20and%20release%E2%80%99%20icy%20post-punk%20on%20their%20self-titled%20EP%20-%20https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F" class="tipi-tip tipi-tip-move share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i></span></a><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F" class="tipi-tip tipi-tip-move share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i></span></a><a href="fb-messenger://share/?link=https%3A%2F%2Fvanyaland.com%2F2020%2F10%2F16%2Fpeel-catch-and-release-icy-post-punk-on-their-self-titled-ep%2F" class="tipi-tip tipi-tip-move tipi-xl-0 share-button share-button-msg" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-messenger"></i></span></a>	</div>
</div>
<script type="application/ld+json">{"@context": "http://schema.org",
	"@type": "WebPage",
	"name": "Vanyaland",
	"description": "Music, Film &amp; Beyond","url": "https://vanyaland.com/","datePublished": "2020-10-16T14:01:59-04:00","dateCreated": "2020-10-16T14:01:59-04:00","dateModified": "2020-10-16T14:12:43-04:00","sameAs": ["https://facebook.com/vanyaland617","https://twitter.com/vanyaland617"],"potentialAction": {
	"@type": "SearchAction",
	"target": "https://vanyaland.com/?s=&#123;search_term&#125;",
	"query-input": "required name=search_term"}}</script><style id='zeen-logo-inline-css' type='text/css'>
@media only screen and (min-width: 1200px) {.logo-main img{ display:inline-block; width:50px; height:50px;}}
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/vanyaland.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/vanyaland.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LfzYpUUAAAAAHhFhJLqocoYhwa9B97xqIG26Z_j&#038;ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LfzYpUUAAAAAHhFhJLqocoYhwa9B97xqIG26Z_j","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/gsap/gsap.min.js?ver=3.4'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/gsap/ScrollTrigger.min.js?ver=3.4'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/js.cookie.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/flickity.pkgd.min.js?ver=2.2.0'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/menu-aim.min.js?ver=1.9.0'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/intersection-observer.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/swipebox.min.js?ver=1.4.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var zeenJS = {"root":"https:\/\/vanyaland.com\/wp-json\/codetipi-zeen\/v1\/","nonce":"1a33b0ea5d","qry":{"page":0,"year":2020,"monthnum":10,"day":16,"name":"peel-catch-and-release-icy-post-punk-on-their-self-titled-ep","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":12,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"args":{"sDelay":5000,"subL":false,"lazy":true,"lazyNative":false,"iconSorter":"<i class=\"tipi-i-chevron-down\"><\/i>","iplComs":false,"heroFade":0.075,"iplMob":true,"infUrlChange":true,"fbComs":false,"lightbox":true,"lightboxChoice":1,"archiveUrlChange":true,"stickyHeaderCustomize":false,"cookieDuration":90,"searchPpp":3,"iplCached":true,"path":"\/","disqus":false,"subCookie":true,"pluginsUrl":"https:\/\/vanyaland.com\/wp-content\/plugins","frontpage":false,"ipl":[]},"i18n":{"embedError":"There was a problem with your embed code. Please refer to the documentation for help.","loadMore":"Load More","noMore":"No More Content"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://vanyaland.com/wp-content/themes/redefined_theme/assets/js/functions.min.js?ver=3.9.4'></script>
<script type='text/javascript' src='https://www.google-analytics.com/analytics.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://vanyaland.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
</body>
</html>